Ways to Import Multiple Choice Questions into Moodle

You can import a large number of multiple choice questions into Moodle in one step.

If you have a bank of multiple choice questions in a word or text document that you would like to import into Moodle, it is necessary to first format them in a way that Moodle will recognize. A good choice is Aiken format, which probably resembles your existing questions, and can be achieved quickly using the Find and Replace function on Notepad.

Aiken format looks like this:

What is the correct answer to this question?

A. Is it this one?

B. Maybe this answer?

C. Possibly this one?

D. Must be this one!

ANSWER: D

Which LMS has the most quiz import formats?

A) Moodle

B) ATutor

C) Claroline

D) Blackboard

E) WebCT

F) Ilias

ANSWER: A

In Aiken format, you get one line for the question. If your question is longer, you can still put it on a single line if you are using a text editor like Notepad. Under the Format tab, turn off Word Wrap, and you will see the question all on one line.

Once you have your questions in Aiken format, save them as a TXT file, choosing the UTF-8 encoding from the menu. This file is now ready for import in Aiken format.

To import, decide into which category you want to import these questions. Before importing, go to the question bank (Course Administration -> Question Bank) and select a category. Now when you go back to the side menu and choose Course Administration -> Question Bank -> Import, this will be the category into which it will import.

Once in the Import page, choose the Aiken file format, then choose your file, and click Import.  If you have formatted properly, all of your questions will now be in the question bank, in the category that you selected. If you made a mistake in formatting, Moodle will import the questions up to the one with the mistake, then stop. You will have to go back to your TXT document and correct the formatting.

If you are making multiple choice questions from scratch, you may also wish to use this method rather than typing them directly into Moodle, as it is a reader-friendly format that is better than what you can get by exporting from Moodle.

Another source of multiple choice questions may be a purchased test bank. For example, some of you might have the Computerized Assessment Banks that are available along with the high school math resources. These use the ExamView test generator and the questions are in an ExamView format. Ignore the fact that Moodle lists ExamView as an acceptable question format. Instead, follow these steps:

1) Use the Quick Test Wizard in the ExamView Test Generator to create a test. Select all of the questions that you want to import into the category that you have selected. Click Finish to build the test.

2) From the File menu, choose Export -> Blackboard 6.0-7.0. Give the file a name, and then enter the same name as the Pool Name and Image Directory in the next window, and click OK. It will export the file to your chosen location.

3) To import into Moodle, go to the side menu and choose Course Administration -> Question Bank -> Import. Once on that page, choose the Blackboard format, then choose your file in the Import Questions from File section. Click Import.

4) Your questions will now be in the Question Bank. Note that this works with all types of questions, not just multiple choice, and it imports formulas and images very well. Note that some types of questions will not self-mark.

5) This will create a category for you in the question bank. If you would like to change how your categories are arranged or make it a sub-category of another category, this is easily done by going to the side menu and choosing Course Administration -> Question Bank -> Categories.

You cannot import calculated questions into Moodle. However, you can easily use the dynamic questions in ExamView to create a new set of questions. Go back to the test that you created in step 1. Make sure that Question Tags is checked on the View menu. Now, delete any questions on the test that do not have a calculator icon to the left of the question number.

Next, highlight the name of the test and click the calculator icon in the top toolbar. This will recalculate the values in each of the questions and give you a new set of questions.  Follow steps 1-5 above. In step 5, if you wish to put them into the category already created, open the new category, select all questions, and scroll down to the bottom of the page, where there is a “Move to” option.

https://docs.moodle.org/28/en/Aiken_format

https://docs.moodle.org/28/en/Import_questions#Examview


Questions or comments? Please contact Carla.Lorer@sunwestsd.ca